PHP is amongst the most commonly used open-source programming languages. It’s extremely popular because it’s free software, which you can use to build interactive sites such as community portals, online shopping portals or online teaching sites as opposed to static HTML-based sites. A PHP module must be available on the web server where a PHP-powered website is hosted so that its PHP code can be ‘translated’. As there aren’t any license taxes for this sort of module and the language offers unlimited options for the applications that you create, there are 100s of millions of PHP-powered websites. Furthermore, there are an enormous number of PHP-based scripts, which you can use for your websites without the need to have any programming knowledge. Considering the fact that there are a couple of PHP versions, you must make sure that the same version that you used whilst setting up your site is installed on the server too.

PHP 4 and PHP 5 Support in Website Hosting

With our Linux website hosting, you’ll be able to pick the version of PHP that will be enabled for your web hosting account, since several versions are installed on our servers. With just one click of the mouse, you’ll be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and anytime a new version is published in the future, we will add it to the Hepsia Control Panel without removing the older ones. In this way, you will be able to host all the sites that you’ve created through the years. In contrast with many other web hosting suppliers, we won’t force you to update such websites, as a script may be out of date, but this does not automatically mean that it’s insecure as you may have modified its source code to plug security loopholes. For your convenience, you will even be able to choose a different PHP version for each individual website that you host in your shared hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Our Linux semi-dedicated hosting support multiple versions of PHP, so you will be able to run all the web applications that you’ve set up through the years. The Hepsia hosting Control Panel, which comes with each and every semi-dedicated account, will allow you to set the required version with one click. You can choose between PHP 4, 5.2, 5.3, 5.4 and 5.5. In case you want to host multiple websites in a single account and they have different requirements respecting the hosting environment, you will be able to choose a different version for each of them no matter which version has been selected for the account as a whole. That’s achievable thanks to our custom-developed cloud hosting platform, which allows us to run several versions of PHP all at the same time. In stark comparison, the majority of hosting vendors normally offer one, sometimes two versions.